CMS MADE SIMPLE FORGE

CMS Made Simple Core

 

[#11509] Upgrade from specific versions corrupts core modules

avatar
Created By: Matt Hornsby (DIGI3) (DIGI3)
Date Submitted: Tue Jul 25 10:48:04 -0400 2017

Assigned To:
Version: 2.2.2
CMSMS Version: 2.2.2
Severity: Minor
Resolution: Fixed
State: Open
Summary:
Upgrade from specific versions corrupts core modules
Detailed Description:
When upgrading from versions  2.1.1 or 2.1.2 to 2.2.2, the upgrade finishes
without error, but the core modules all show that they are in need of upgrade in
MoMa. When you try to upgrade them, you get the error "The CMSMS core must be
upgraded before this operation can succeed".

Steps to reproduce:
1) upgrade 2.1.1 or 2.1.2 to 2.2.2 using the regular Phar installer (haven't
tested expanded)
2) log in to the upgraded site and go to Module Manager

Workaround:
1) restore from backup
2) upgrade to 2.1.5 first, then 2.2.2


History

Comments
avatar
Date: 2017-07-25 10:54
Posted By: Tristan (tristan)

Can confirm! Exactly the same problem here with 2.1.1 to 2.2.2 upgrade. Maybe
there should be a warning in the installer when trying to update from this
version to 2.2.2?
      
avatar
Date: 2017-08-18 07:57
Posted By: Tomas Amsrud (tamsrud)

I experience the same problem when upgrading from v2.1.4 to v2.2.2
      
avatar
Date: 2017-08-18 08:50
Posted By: Tomas Amsrud (tamsrud)

Extra info:
The get_installed_schema_version() function returns 201 while the
CMS_SCHEMA_VERSION is set to 202.

No errors during upgrade.
      
avatar
Date: 2017-09-03 10:49
Posted By: Matt Hornsby (DIGI3) (DIGI3)

Fixed in 2.2.3.1 (commenters please verify)
      
avatar
Date: 2017-09-07 09:23
Posted By: Robert Campbell (calguy1000)

Fixed in 2.2.3
      
Updates

Updated: 2017-09-07 09:23
resolution_id: => 7